viernes, 13 de abril de 2018

Packet Tracer 7.1 en Ubuntu 16.04.4, 64 bits

Hola amigos, en este apunte vamos a agregar un software bastante utilizado en redes informáticas, incluso en las nuevas versiones de PT(packettracer) se puede usar internet del todo, cada vez se puede hacer más cosas.

La situación es que yo atualicé mi Ubuntu xfce, decidí de tiempo usar a mi "ratoncito" y dije pues quiero usar PT aquí y mirando en la web www.netacad.com pues veo que está disponible para la versión 7.1, pero para Ubuntu 14.x, para descargar es un archivo .tar, por cierto el registro en netacad es gratis, y puedes descargar PT y probar tus habilidades en dicho software.

Unos dirán por qué usas Ubuntu, la razón es simple, tiene más soporte a hardware, tiene una comunidad con usuarios activos, ya tiene bastante tiempo y como ven Cisco ofrece el software para Ubuntu, si se puede utilizar en otra pues bien, en este caso aquí es Ubuntu.

Nos registramos y descargamos





Nos ubicamos en la carpeta y vamos a añadir el software como usuario root, o usa sudo, pero primero vamos a descomprimir.

$sudo tar -xf elpacketracer.tar
 
Luego usa ls para ver que ya ha descomprimido

Luego vamos a ejecutar el archivo ejecutable install (el color verde en la imagen arriba)

$sudo ./install

Con enter lees toda la licencia, llegas al 100% y aceptas con y

sigues las instrucciones y parece que todo ha instalado satisfactoriamente y OH sorpresa, no funciona jeej, haciendo un seguimiento pues nos damos cuenta y justamente lo que sospechaba, Cisco da soporte para Ubuntu 14 y yo tengo la release LTS 16.x, dije algo no va a funcionar, pero intentemos...

Pues si hay un paquete que esta versión necesita y es una versión antigua no la actual que incluye nuestro "ratoncito", pues buscando en internet, encontré un tutorial, pero el enlace esta "roto", pero con su nombre lo busqué ahí mismo y lo encontre, este enlace es el que necesitamos, el archivo a descargar AQUI, pues en la misma terminal lo descargamos con wget

$wget http://security.ubuntu.com/ubuntu/pool/main/i/icu/libicu52_52.1-3_amd64.deb

Luego con superusuario con dpkg lo instalas a esa dependencia que necesitas.

$sudo dpkg -i libicu52_52.1-3_amd64.deb

OJO pues si necesitas la 52 y no como Ubuntu actual tiene, la 55, con locale lo pues ver

$sudo updatedb; locate libicui18n

Pues ahora va a funcionar, pero desde la terminal, osea

edgar@NotebookEdgar:~$ packettracer
Starting Packet Tracer 7.1.1

No es practico, depende de quien lo usa el ordenador, pero que pasa si lo hacemos bonito, añadimos al menu del ratoncito, por cierto actualmente ya está, pero sigue sin funcionar, reinicias el ordenador y nada, pero desde la terminal si funciona con nuestro nuevo paquete 52.

Una forma es añadir ALACARTE y decir que comando ejecutar y le añadimos un icono y todo va a quedar bonito, sigue las imágenes.

$sudo apt-get install alacarte

Presionas las teclas alt+f2 y lanza una ventana de dialogo, escribes alacarte e inicias.

Presiona ejecutar


Escribes en Name Packet Tracer, en command escribes este comando, pero antes consulta dónde esta ese script packettracer que escribes en la terminal yb funciona:

edgar@NotebookEdgar:~$ locate packettracer
/home/edgar/Descargas/PT/tpl.packettracer
/opt/pt/packettracer
/opt/pt/tpl.packettracer
/usr/local/bin/packettracer
Ahi esta el script, eso escribes en command.

En coment pues puedes poner algún comentario, recuerda que ypo estoy añadiendo en el menú educación, tu puedes añadir en otro sitio :), para la imágen de icono pues haces clic en ese cuadrito al lado izquierdo y buscas la carpeta /opt/pt/art/ ahi hay iconos, el PT el general era app.png, yo usé otro jejee, pero igual ya tengo uno de los iconos, luego vas al menú del ratoncito y buscas tu icono.


Le haces clic ya funciona jeje


Recuerda que tienes que ingresar en el primer tiempo con tu usuario y contraseña, enjoy!

Tutorial seguido: https://www.tech-otaku.com/linux/getting-cisco-packet-tracer-71-to-run-on-ubuntu-1604-lts/






No hay comentarios.:

Publicar un comentario